Eclipse Kepler + Java 8: Syntax error, annotations are only available if source level is 1.5 or greater

twittergoogle_plusrss

Facebooktwittergoogle_plusredditlinkedinmail

When I configured project with Spring, Maven and Java 8, my Eclipse showed a lot of errors. I noticed mostly refusing to accept annotations:

Syntax error, annotations are only available if source level is 1.5 or greater.

Eclipse Kepler doesn’t have built in support for JDK8. So there is needed to install JDT with Java8 support.

I use Spring Tools Suite 3.5.0.RELEASE, which  is still based on Eclipse Kepler (4.3.2). That is why STS needs this update.

twittergoogle_plusrss

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.